Login | Register
My pages Projects Community openCollabNet

Discussions > users [DISABLED] > Re: Install troubles with version 1.6

subversion
Discussion topic

Back to topic list

Re: Install troubles with version 1.6

Author Ed <SVN at 0x1b dot com>
Full name Ed <SVN at 0x1b dot com>
Date 2009-04-06 17:39:28 PDT
Message On Fri, Apr 3, 2009 at 5:21 PM, Tom Browder <tom dot browder at gmail dot com> wrote:
> On Fri, Apr 3, 2009 at 6:00 AM, Andrea Antonio Maleci
> <A dot Maleci at iwbank dot it> wrote:
>> Hi Patricia,
> ...
>> I don't know how to rectify the ./configure error so that I can get a clean
>> compile.
>> Can someone shed light?  Thanks
>
> I believe the subversion configuration system is not very robust.  Try
> to download and separately install apr and apr-util.  They use a
> special configuration configuration script that does the same function
> as pkg-config.
>
> In any case, try to find 'apr-1-config' and 'apu-1-config' on your system:
>
>  `which apr-1-config`
>  `which apu-1-config'
>
> Assuming both are found try:
>
>  ./configure --with-apr=`which apr-1-config` --with-apr-util=`which
> apu-1-config`
>
> Note those are backward quotes surrounding `which ap[ru]-1-config`.
>
> -Tom
>

Take care that the httpd/apr/apr-util etc use the same dependencies as
Subversion - mixed versions of the Berkeley db, for example, are a
pain to figure out the first time..
if you are compiling httpd yourself, the svn-deps package isn't needed
- either satisfy the dependencies yourself or use the svn-deps
tarball, but don't do both because you will get a bad case of
tanglfoot.

^Ed

« Previous message in topic | 4 of 20 | Next message in topic »

Messages

Show all messages in topic

Install troubles with version 1.6 Patricia A Moss <pmoss4 at csc dot com> Patricia A Moss <pmoss4 at csc dot com> 2009-04-02 12:02:43 PDT
     RE: Install troubles with version 1.6 Andrea Antonio Maleci <A dot Maleci at iwbank dot it> Andrea Antonio Maleci <A dot Maleci at iwbank dot it> 2009-04-03 04:00:45 PDT
         Re: Install troubles with version 1.6 Tom Browder <tom dot browder at gmail dot com> Tom Browder <tom dot browder at gmail dot com> 2009-04-03 17:21:13 PDT
             Re: Install troubles with version 1.6 Ed <SVN at 0x1b dot com> Ed <SVN at 0x1b dot com> 2009-04-06 17:39:28 PDT
                 Re: Install troubles with version 1.6 Patricia A Moss <pmoss4 at csc dot com> Patricia A Moss <pmoss4 at csc dot com> 2009-04-07 04:05:17 PDT
                     Re: Install troubles with version 1.6 Tom Browder <tom dot browder at gmail dot com> Tom Browder <tom dot browder at gmail dot com> 2009-04-07 05:25:23 PDT
                         Re: Install troubles with version 1.6 Patricia A Moss <pmoss4 at csc dot com> Patricia A Moss <pmoss4 at csc dot com> 2009-04-07 05:41:13 PDT
                             RE: Install troubles with version 1.6 Andrea Antonio Maleci <A dot Maleci at iwbank dot it> Andrea Antonio Maleci <A dot Maleci at iwbank dot it> 2009-04-07 06:37:00 PDT
                                 RE: Install troubles with version 1.6 Patricia A Moss <pmoss4 at csc dot com> Patricia A Moss <pmoss4 at csc dot com> 2009-04-07 06:51:26 PDT
                             Re: Install troubles with version 1.6 Tom Browder <tom dot browder at gmail dot com> Tom Browder <tom dot browder at gmail dot com> 2009-04-07 07:23:51 PDT
                         Re: Install troubles with version 1.6 Patricia A Moss <pmoss4 at csc dot com> Patricia A Moss <pmoss4 at csc dot com> 2009-04-07 06:43:06 PDT
                             Re: Install troubles with version 1.6 Andrey Repin <anrdaemon at freemail dot ru> Andrey Repin <anrdaemon at freemail dot ru> 2009-04-07 07:30:01 PDT
                                 Re: Install troubles with version 1.6 Patricia A Moss <pmoss4 at csc dot com> Patricia A Moss <pmoss4 at csc dot com> 2009-04-07 08:20:32 PDT
                                     Re: Install troubles with version 1.6 tylermr Tyler Roscoe 2009-04-07 08:37:10 PDT
                                     Re: Install troubles with version 1.6 Andrey Repin <anrdaemon at freemail dot ru> Andrey Repin <anrdaemon at freemail dot ru> 2009-04-07 08:55:01 PDT
                                         RE: Install troubles with version 1.6 pilotbob Bob Archer 2009-04-07 09:37:10 PDT
                                     RE: Install troubles with version 1.6 "Tony Sweeney" <tsweeney at omnifone dot com> "Tony Sweeney" <tsweeney at omnifone dot com> 2009-04-07 08:59:38 PDT
                                 Re: Install troubles with version 1.6 Patricia A Moss <pmoss4 at csc dot com> Patricia A Moss <pmoss4 at csc dot com> 2009-04-07 09:06:49 PDT
                                     Re: Install troubles with version 1.6 Andrey Repin <anrdaemon at freemail dot ru> Andrey Repin <anrdaemon at freemail dot ru> 2009-04-07 09:30:03 PDT
                                 Re: Install troubles with version 1.6 Patricia A Moss <pmoss4 at csc dot com> Patricia A Moss <pmoss4 at csc dot com> 2009-04-07 09:09:54 PDT
Messages per page: