Login | Register
My pages Projects Community openCollabNet

Discussions > users [DISABLED] > Re: strange bug with propget/proplist/propedit via mod_dav_svn

subversion
Discussion topic

Back to topic list

Re: strange bug with propget/proplist/propedit via mod_dav_svn

Author Sergey Kryzhny <sergey dot kryzhny at gmail dot com>
Full name Sergey Kryzhny <sergey dot kryzhny at gmail dot com>
Date 2009-04-10 00:48:28 PDT
Message Hi Ryan!


2009/4/9 Ryan Schmidt <subversion-2009a​@ryandesign.com>

>
> On Apr 9, 2009, at 05:19, Sergey Kryzhny wrote:
>
> I try to implement pre-revprop-change hook for change svn:log message and
>> run into problem with access via apache mod_dav_svn.
>> Everything work fine via EDITOR=nano svn propedit -r 16385 --revprop
>> svn:log file:///mnt/svn/repo​sitories/projects/
>> I get back string like "fixin foo/bar JIRA-blah-blah" and can edit/set new
>> message.
>> But if I use EDITOR=nano svn propedit -r 16385 --revprop svn:log
>> http://svn1.mycompan​y.org/projects/
>> on same host or via internet / intranet I get empty response string.
>> Same behavior for propget and proplist. Proplist does not return property
>> list via dav.
>>
>> Tried different windows/linux client.
>> Tried different versions of subversion: 1.4.4 via yum on Fedora7, 1.5.4
>> via yum on Fedora 10, 1.6.0 build from sources on Fedora10, 1.4.6 on Ubuntu
>> 8.04
>> Tried FSFS and BDB repository.
>> Tried Dump/Load repository and svnadmin upgrade repository.
>>
>> Very strange that for some repository revision it work normally for both
>> file/dav access. -> so hooks are OK.
>> Like for revision 12570 it work, for revision 16385 it dosen't work via
>> dav.
>>
>> And most mistycal that if I rename my repository (on host local FS) from
>> "projects" to some other name like "projects2" or "projects.orig" it start
>> work via dav!!!!
>> I even try to symlink directory "projects" to "projects2" - work on
>> "projects2" and dosen't work on "projects" !!!
>>
>> Any ideas to resolve this strange bug?
>>
>
> Perhaps there is some other Apache directive matching on the string
> "projects" and interfering. Search your httpd.conf and any other files it
> includes for the string "projects".
>
>
Only one string in apache configs match projects:
            RedirectMatch "^/?$" "/projects/"

I don't think this may be problem, with some revisions in svn repository
propget works, with some don't work.
If I use mod_proxy redirection from /projects to renamed "projects2"
repository - forks fine.

--
--
Best regards,
Sergey
Attachments

« Previous message in topic | 4 of 5 | Next message in topic »

Messages

Show all messages in topic

strange bug with propget/proplist/propedit via mod_dav_svn Sergey Kryzhny <sergey dot kryzhny at gmail dot com> Sergey Kryzhny <sergey dot kryzhny at gmail dot com> 2009-04-09 03:19:28 PDT
     Re: strange bug with propget/proplist/propedit via mod_dav_svn Sergey Kryzhny <sergey dot kryzhny at gmail dot com> Sergey Kryzhny <sergey dot kryzhny at gmail dot com> 2009-04-09 05:08:41 PDT
     Re: strange bug with propget/proplist/propedit via mod_dav_svn ryandesign Ryan Schmidt 2009-04-09 13:49:35 PDT
         Re: strange bug with propget/proplist/propedit via mod_dav_svn Sergey Kryzhny <sergey dot kryzhny at gmail dot com> Sergey Kryzhny <sergey dot kryzhny at gmail dot com> 2009-04-10 00:48:28 PDT
     Re: strange bug with propget/proplist/propedit via mod_dav_svn Andrey Repin <anrdaemon at freemail dot ru> Andrey Repin <anrdaemon at freemail dot ru> 2009-04-09 16:04:38 PDT
Messages per page: