Login | Register
My pages Projects Community openCollabNet

Discussions > users [DISABLED] > Subversion and Windows XP WebDAV mini redirector problem

subversion
Discussion topic

Back to topic list

Subversion and Windows XP WebDAV mini redirector problem

Author Johan Ymerson <johan dot ymerson at transmode dot se>
Full name Johan Ymerson <johan dot ymerson at transmode dot se>
Date 2009-04-15 07:13:10 PDT
Message Hi,

I have tried to set up Subversion with Apache to supply WebDAV access for Windows XP clients.
We need to use the Windows XP mini redirector driver to map a network drive to the Subversion repository, like:
net use v: http://server/repo

I know there are problems with authentication against apache, but I have worked around that by using Kerberos (this is in a AD domain):
<Location /Common>
      DAV svn
      SVNPath /var/svn/Common
      SVNIndexXSLT "/index.xsl"
      SVNPathAuthz off

      AuthName "transmode.se"
      AuthType Kerberos
      Krb5Keytab /etc/apache2/krb5.svn.keytab
      KrbAuthRealms TRANSMODE.SE
      KrbMethodNegotiate on
      KrbSaveCredentials off
      KrbVerifyKDC on
      KrbServiceName HTTP/svn.transmode.se
      KrbLocalUserMapping on
      AuthDBMGroupFile /etc/apache2/group.cache

      Require valid-user
</Location>

This works great with the ordinary DAV driver (DAV on), I can map the WebDAV directory as a drive with the above command.
But when using Subversion (DAV svn), it fails with the following error:
c:\>net use v: http://server/Common
System error 67 has occured.

The network name cannot be found
c:\>

I get no error messages in the server.

All problems I have seen reported about the Windows XP mini redirector is about the authentication, but in this case the authentication works, and also the normal file system backed DAV module works.

Does anyone know what could be the problem, or how to debug this?

/Johan Ymerson

« Previous message in topic | 1 of 1 | Next message in topic »

Messages

Show all messages in topic

Subversion and Windows XP WebDAV mini redirector problem Johan Ymerson <johan dot ymerson at transmode dot se> Johan Ymerson <johan dot ymerson at transmode dot se> 2009-04-15 07:13:10 PDT
Messages per page: