Login | Register
My pages Projects Community openCollabNet

Discussions > users [DISABLED] > Re: 1.6.1 not working with ssh in Cygwin

subversion
Discussion topic

Back to topic list

Re: 1.6.1 not working with ssh in Cygwin

Author Duncan Murdoch <murdoch at stats dot uwo dot ca>
Full name Duncan Murdoch <murdoch at stats dot uwo dot ca>
Date 2009-04-16 03:22:21 PDT
Message Andrey Repin wrote:
> Greetings, Duncan Murdoch!
>
>
>>>> I use Cygwin and its OpenSSH for accessing svn+ssh repositories. This
>>>> worked fine up to 1.5.0, but I just upgraded to 1.6.1, and svn hangs
>>>> when trying to do anything with one of those repositories. (It's fine
>>>> working with https). For example, "svn up" or "svn log" will sit there
>>>> doing nothing; after I break it needs a cleanup, which works.
>>>>
>>>> Any hints on what has changed? This is quite frustrating...
>>>>
>>>>
>>> Quite possibly http://subversion.ti​gris.org/issues/show​_bug.cgi?id=2580
>>>
>>>
>>>
>
>
>> Maybe, though it doesn't look exactly right. But if there's a nightly
>> build somewhere that incorporates a fix for this, I'll give it a try.
>> (I'm on 32 bit Windows).
>>
>
> I'd recommend to compile SVN yourself against Cygwin1.dll if you're to use
> Cygwin.
>
>

This has never been necessary in the past, and I'm not set up with the
Cygwin versions of the compilers. I've got the MinGW compilers set up,
but they don't use Cygwin dlls. I'll see if Cygwin has binary builds of
svn available to download.

Duncan Murdoch
> --
> WBR,
> Andrey Repin (anrdaemon at freemail dot ru) 16.04.2009, <4:57>
>
> Sorry for my terrible english...
>
> --------------------​--------------------​--------------
> http://subversion.ti​gris.org/ds/viewMess​age.do?dsForumId=106​5&dsMessageId=17​36267
>
> To unsubscribe from this discussion, e-mail: [users-unsubscribe@s​ubversion.tigris.org​].
>

« Previous message in topic | 5 of 6 | Next message in topic »

Messages

Show all messages in topic

1.6.1 not working with ssh in Cygwin Duncan Murdoch <murdoch at stats dot uwo dot ca> Duncan Murdoch <murdoch at stats dot uwo dot ca> 2009-04-15 13:57:18 PDT
     Re: 1.6.1 not working with ssh in Cygwin stsp Stefan Sperling 2009-04-15 14:41:00 PDT
         Re: 1.6.1 not working with ssh in Cygwin Duncan Murdoch <murdoch at stats dot uwo dot ca> Duncan Murdoch <murdoch at stats dot uwo dot ca> 2009-04-15 15:23:39 PDT
             Re: 1.6.1 not working with ssh in Cygwin Andrey Repin <anrdaemon at freemail dot ru> Andrey Repin <anrdaemon at freemail dot ru> 2009-04-15 18:00:05 PDT
                 Re: 1.6.1 not working with ssh in Cygwin Duncan Murdoch <murdoch at stats dot uwo dot ca> Duncan Murdoch <murdoch at stats dot uwo dot ca> 2009-04-16 03:22:21 PDT
                 Re: 1.6.1 not working with ssh in Cygwin Duncan Murdoch <murdoch at stats dot uwo dot ca> Duncan Murdoch <murdoch at stats dot uwo dot ca> 2009-04-16 03:53:10 PDT
Messages per page: