Login | Register
My pages Projects Community openCollabNet

Discussions > users [DISABLED] > Re: svn error when checkout using tortoise

subversion
Discussion topic

Back to topic list

Re: svn error when checkout using tortoise

Author westalto
Full name west alto
Date 2009-10-06 05:19:34 PDT
Message The attached file is the error when i checkout using tortoisesvn



On Tue, Oct 6, 2009 at 7:47 PM, west alto <westalto at gmail dot com> wrote:

>
> Hi Gurus,
>
> I'm having a problem when i checkout large repository using tortoisesvn but
> when using linux client from cli i dont experience this problem:
>
> [Tue Oct 06 19:33:51 2009] [debug] mod_authnz_ldap.c(373): [client
> 192.168.80.161] [28912] auth_ldap authenticate: using URL
> ldaps://windowsad.se​rver.local:636/DC=se​rver,DC=local?sAMAcc​ountName?sub?(object​Class=user)
> [Tue Oct 06 19:33:51 2009] [debug] mod_authnz_ldap.c(445): [client
> 192.168.80.161] [28912] auth_ldap authenticate: accepting user
> [Tue Oct 06 19:33:51 2009] [info] [client 192.168.80.161] Access granted:
> 'user' GET my_repos:/abc/trunk/​bin/file1.prog
> [Tue Oct 06 19:33:51 2009] [debug] mod_authnz_ldap.c(373): [client
> 192.168.80.161] [28912] auth_ldap authenticate: using URL
> ldaps://windowsad.se​rver.local:636/DC=se​rver,DC=local?sAMAcc​ountName?sub?(object​Class=user)
> [Tue Oct 06 19:33:51 2009] [debug] mod_authnz_ldap.c(445): [client
> 192.168.80.161] [28912] auth_ldap authenticate: accepting user
> [Tue Oct 06 19:33:51 2009] [info] [client 192.168.80.161] Access granted:
> 'user' GET my_repos:/abc/trunk/​bin/file2.dat
> [Tue Oct 06 19:33:51 2009] [debug] mod_authnz_ldap.c(373): [client
> 192.168.80.161] [28912] auth_ldap authenticate: using URL
> ldaps://windowsad.se​rver.local:636/DC=se​rver,DC=local?sAMAcc​ountName?sub?(object​Class=user)
> [Tue Oct 06 19:33:51 2009] [debug] mod_authnz_ldap.c(445): [client
> 192.168.80.161] [28912] auth_ldap authenticate: accepting user
> [Tue Oct 06 19:33:51 2009] [info] [client 192.168.80.161] Access granted:
> 'user' GET my_repos:/abc/trunk/​bin/file3.prog
> [Tue Oct 06 19:33:51 2009] [debug] mod_authnz_ldap.c(373): [client
> 192.168.80.161] [28912] auth_ldap authenticate: using URL
> ldaps://windowsad.se​rver.local:636/DC=se​rver,DC=local?sAMAcc​ountName?sub?(object​Class=user)
> [Tue Oct 06 19:33:51 2009] [debug] mod_authnz_ldap.c(445): [client
> 192.168.80.161] [28912] auth_ldap authenticate: accepting user
> [Tue Oct 06 19:33:51 2009] [info] [client 192.168.80.161] Access granted:
> 'user' GET my_repos:/abc/trunk/​bin/file4.ctl
> [Tue Oct 06 19:33:51 2009] [debug] mod_authnz_ldap.c(373): [client
> 192.168.80.161] [28912] auth_ldap authenticate: using URL
> ldaps://windowsad.se​rver.local:636/DC=se​rver,DC=local?sAMAcc​ountName?sub?(object​Class=user)
> [Tue Oct 06 19:33:51 2009] [debug] mod_authnz_ldap.c(445): [client
> 192.168.80.161] [28912] auth_ldap authenticate: accepting user
> [Tue Oct 06 19:33:51 2009] [info] [client 192.168.80.161] Access granted:
> 'user' GET my_repos:/abc/trunk/​bin/file5.csv
> [Tue Oct 06 19:34:11 2009] [info] [client 192.168.80.161] (104)Connection
> reset by peer: core_output_filter: writing data to the network
> [Tue Oct 06 19:34:11 2009] [info] [client 192.168.80.161] (104)Connection
> reset by peer: SSL output filter write failed.
> [Tue Oct 06 19:34:11 2009] [error] [client 192.168.80.161] Provider
> encountered an error while streaming a REPORT response. [500, #0]
> [Tue Oct 06 19:34:11 2009] [error] [client 192.168.80.161] A failure
> occurred while driving the update report editor [500, #104]
> [Tue Oct 06 19:34:11 2009] [error] [client 192.168.80.161] Error writing
> base64 data: Connection reset by peer [500, #104]
>
>
> The primary purpose why is use ssl to encrypt the transmission of username
> and password. Is there a way to encrypt only the username/password pop-up
> for the the apache authentication and redirect to http after authentication?
> if this is not possible kindly help me with some trick to tweak my apache
> svn configuration.
>
>
> Server specs:
>
> SLES10
> subversion-server-1.5.0-119.1
> apache2-prefork-2.2.0-21.2
> apache2-2.2.0-21.2
>
>
> <IfDefine SSL>
> <IfDefine !NOSSL>
> <VirtualHost _default_:443>
> ServerAdmin admin at server dot local
> ServerName 192.168.9.226:443
> HostnameLookups Off
> UseCanonicalName Off
> ServerSignature On
>
> ErrorLog /var/log/apache2/svn​_ssl-error_log
> TransferLog /var/log/apache2/svn​_ssl-access_log
> CustomLog /var/log/apache2/svn​_ssl-activity_log "%t %u %{SVN-ACTION}e"
> env=SVN-ACTION
>
> SSLEngine on
> SSLCertificateFile /etc/apache2/ssl.crt​/192.168.9.226.crt
> SSLCertificateKeyFile /etc/apache2/ssl.key​/192.168.9.226.key
> SSLProtocol all
> SSLCipherSuite HIGH:MEDIUM
>
> SetEnvIf User-Agent ".*MSIE.*" \
> nokeepalive ssl-unclean-shutdown \
> downgrade-1.0 force-response-1.0
>
> LDAPTrustedClientCert CERT_BASE64
> /etc/apache2/ssl.crt​/windowsad_2017.cer
>
> LogLevel debug
>
> <Location />
> AuthName "Please use your ACTIVE DIRECTORY for Authentication"
> AuthType Basic
> AuthBasicProvider ldap
> AuthzLDAPAuthoritative on
> Include /etc/apache2/.ldapbinddn
> AuthLDAPURL
> "ldaps://windowsad.s​erver.local:636/DC=s​erver,DC=local?sAMAc​countName?sub?(objec​tClass=user)"
> SSLRequireSSL
> Require valid-user
> </Location>
>
> <Location /my_repos>
> DAV svn
> SVNPath /srv/svn/my_repos
> AuthzSVNAccessFile /etc/apache2/AuthzSV​NAccessFile_my_repos​
> </Location>
>
> <Location /repo1>
> DAV svn
> SVNPath /srv/svn/repo1
> AuthzSVNAccessFile /etc/apache2/AuthzSV​NAccessFile_repo1
> </Location>
>
> <Location /repo2>
> DAV svn
> SVNPath /srv/svn/adbrm_repo2
> AuthzSVNAccessFile /etc/apache2/AuthzSV​NAccessFile_repo2
> </Location>
>
> <Location /repo3>
> DAV svn
> SVNPath /srv/svn/repo3
> AuthzSVNAccessFile /etc/apache2/AuthzSV​NAccessFile_repo3
> </Location>
>
> <Location /adbpos_repo4>
> DAV svn
> SVNPath /srv/svn/adbpos_repo4
> AuthzSVNAccessFile /etc/apache2/AuthzSV​NAccessFile_adbpos_r​epo4
> </Location>
>
> </VirtualHost>
> </IfDefine>
> </IfDefine>
>
> <IfDefine SSL>
> <IfDefine !NOSSL>
> <IfModule mod_ssl.c>
>
> AddType application/x-x509-ca-cert .crt
> AddType application/x-pkcs7-crl .crl
> SSLPassPhraseDialog builtin
> SSLSessionCache shmcb:/var/lib/apach​e2/ssl_scache(512000​)
> SSLSessionCacheTimeout 600
> SSLMutex default
> SSLRandomSeed startup builtin
> SSLRandomSeed connect builtin
>
> </IfModule>
> </IfDefine>
> </IfDefine>
>
> Thanks for your help.
>
>
>
> westalto
>
Attachments

« Previous message in topic | 2 of 2 | Next message in topic »

Messages

Show all messages in topic

svn error when checkout using tortoise westalto west alto 2009-10-06 04:47:23 PDT
     Re: svn error when checkout using tortoise westalto west alto 2009-10-06 05:19:34 PDT
Messages per page: