Login | Register
My pages Projects Community openCollabNet

Discussions > dev [DISABLED] > Re: Test failure in the swig-rb tests

subversion
Discussion topic

2020-04-07: This site is going to be decommissioned and shut down on 2020-07-01. Please copy and archive any data you wish to keep before that date.

Back to topic list

Re: Test failure in the swig-rb tests

Author joeswatosh
Full name Joe Swatosh
Date 2009-05-06 15:14:10 PDT
Message On Tue, May 5, 2009 at 10:46 AM, Hyrum K. Wright
<hyrum_wright@mai​l.utexas.edu> wrote:
> Kou, Joe,
> In looking at the bindings buildbot test failures, I noticed the only one is
> for swig-rb:
>
> + echo '========= make check-swig-rb'
> ========= make check-swig-rb
> + make check-swig-rb
> cd
> /home/hwright/dev/sv​n-buildbot/x64-ubunt​u/build/subversion/b​indings/swig/ruby;
> \
>          /usr/bin/ruby -I
> /home/hwright/dev/sv​n-buildbot/x64-ubunt​u/build/subversion/b​indings/swig/ruby
> \
>
>  /home/hwright/dev/s​vn-buildbot/x64-ubun​tu/build/subversion/​bindings/swig/ruby/t​est/run-test.rb
> \
>            --verbose=normal
> Loaded suite .
> Started
> ....................​....................​....................​....................​....................​...............E....​....................​....................​....................​....................​...................
> Finished in 525.212189 seconds.
>
>  1) Error:
> test_apply(SvnDeltaTest):
> ArgumentError: NULL pointer given
> /home/hwright/dev/sv​n-buildbot/x64-ubunt​u/build/subversion/b​indings/swig/ruby/sv​n/util.rb:86:in
> `svn_txdelta_apply_wrapper'
> /home/hwright/dev/sv​n-buildbot/x64-ubunt​u/build/subversion/b​indings/swig/ruby/sv​n/util.rb:86:in
> `txdelta_apply_wrapper'
> /home/hwright/dev/sv​n-buildbot/x64-ubunt​u/build/subversion/b​indings/swig/ruby/sv​n/delta.rb:54:in
> `apply'
> /home/hwright/dev/sv​n-buildbot/x64-ubunt​u/build/subversion/b​indings/swig/ruby/te​st/test_delta.rb:128​:in
> `test_apply'
>
> 219 tests, 1490 assertions, 0 failures, 1 errors
> make: *** [check-swig-rb] Error 1
> + RC=2
> + exit 2
>
>
> Can either of you reproduce this locally?
>
> -Hyrum
>

That test passes for me. (Lots of other failures/errors and a
segfault or two, though).

--
Joe

« Previous message in topic | 2 of 2 | Next message in topic »

Messages

Show all messages in topic

Test failure in the swig-rb tests hwright Hyrum K. Wright 2009-05-05 10:46:44 PDT
     Re: Test failure in the swig-rb tests joeswatosh Joe Swatosh 2009-05-06 15:14:10 PDT
Messages per page: