Login | Register
My pages Projects Community openCollabNet

Discussions > dev [DISABLED] > Re: bug in svn_client_copy wc to url

subversion
Discussion topic

Back to topic list

Re: bug in svn_client_copy wc to url

Author stylesen
Full name Senthil Kumaran S
Date 2009-05-08 03:10:46 PDT
Message Alan Wood wrote:
> Hi All,
> Just been trying to write tests for the first time ( in subversion that is ).
> In the process I came across a seg fault when doing a svn copy wc to url.
>
> There seems to be no check to see if a wc file exists before libsvn_client\copy.c line
> 1096 where it crashes on entry == NULL
>
> SVN_ERR(svn_wc_entry​(&entry, pair->src, adm_access,
> FALSE, iterpool));
> pair->src_revnum = entry->revision;

Yes this is a bug. Alan, are planning to come up with a patch for the same?

Thank You.
--
Senthil Kumaran S
http://www.stylesen.org/

« Previous message in topic | 2 of 9 | Next message in topic »

Messages

Show all messages in topic

bug in svn_client_copy wc to url alwood Alan Wood 2009-05-08 02:47:15 PDT
     Re: bug in svn_client_copy wc to url stylesen Senthil Kumaran S 2009-05-08 03:10:46 PDT
         Re: bug in svn_client_copy wc to url stsp Stefan Sperling 2009-05-08 03:28:03 PDT
             Re: bug in svn_client_copy wc to url alwood Alan Wood 2009-05-08 03:56:12 PDT
                 Re: bug in svn_client_copy wc to url stylesen Senthil Kumaran S 2009-05-08 04:07:39 PDT
                     Re: bug in svn_client_copy wc to url stsp Stefan Sperling 2009-05-08 04:24:51 PDT
                         Re: bug in svn_client_copy wc to url stylesen Senthil Kumaran S 2009-05-08 04:32:19 PDT
         Re: bug in svn_client_copy wc to url alwood Alan Wood 2009-05-08 04:00:21 PDT
             Re: bug in svn_client_copy wc to url stylesen Senthil Kumaran S 2009-05-08 05:15:39 PDT
Messages per page: