Login | Register
My pages Projects Community openCollabNet

Discussions > dev [DISABLED] > Re: parse tlsext bug

subversion
Discussion topic

Back to topic list

Re: parse tlsext bug

Author Joe Orton <jorton at redhat dot com>
Full name Joe Orton <jorton at redhat dot com>
Date 2009-08-04 00:55:31 PDT
Message On Mon, Aug 03, 2009 at 08:17:26PM +0200, Sebastian Krysmanski wrote:
> After some trial and error I found out that the problem (at least the cases
> I could reproduce) only occurs when using Apache HTTPd 2.2.12. After I
> reverted to version 2.2.11 the error was gone (but this can't be a permanent
> solution).

httpd 2.2.12 enabled the TLS SNI extension, which is undoubtedly
related. Could you file a bug against mod_ssl here:

https://issues.apach​e.org/bugzilla/enter​_bug.cgi?product=Apa​che%20httpd-2

(it is possible this bug lies anywhere between neon, OpenSSL and
mod_ssl, but we should first eliminate mod_ssl)

Do you control the server for which this bug can be reproduced? If so
it would be helpful to enable "LogLevel debug" (temporarily) in the
global server configuration, and capture complete mod_ssl debug logs
whilst the problem is reproduced.

Do you also have a precise set of steps I could follow to reproduce the
issue? Could you also find out what version of OpenSSL the server is
using?

Regards, Joe

« Previous message in topic | 2 of 3 | Next message in topic »

Messages

Show all messages in topic

parse tlsext bug "Sebastian Krysmanski" <sebastian at krysmanski dot de> "Sebastian Krysmanski" <sebastian at krysmanski dot de> 2009-08-03 11:17:28 PDT
     Re: parse tlsext bug Joe Orton <jorton at redhat dot com> Joe Orton <jorton at redhat dot com> 2009-08-04 00:55:31 PDT
         AW: parse tlsext bug "Sebastian Krysmanski" <sebastian at krysmanski dot de> "Sebastian Krysmanski" <sebastian at krysmanski dot de> 2009-08-05 02:27:27 PDT
Messages per page: