Login | Register
My pages Projects Community openCollabNet

Discussions > dev [DISABLED] > Re: svn commit: r37806 - trunk/subversion/libsvn_repos

subversion
Discussion topic

2020-04-07: This site is going to be decommissioned and shut down on 2020-07-01. Please copy and archive any data you wish to keep before that date.

Hide all messages in topic

All messages in topic

Re: svn commit: r37806 - trunk/subversion/libsvn_repos

Author neels
Full name Neels Janosch Hofmeyr
Date 2009-05-26 18:18:32 PDT
Message Hyrum K. Wright wrote:
> On May 25, 2009, at 9:19 AM, Stefan Sperling wrote:
>
>> On Mon, May 25, 2009 at 08:08:17AM -0500, Hyrum K. Wright wrote:
>>> On May 24, 2009, at 3:55 PM, Neels Janosch Hofmeyr wrote:
>>>
>>>> Author: neels
>>>> Date: Sun May 24 13:55:35 2009
>>>> New Revision: 37806
>>>>
>>>> Log:
>>>> * subversion/libsvn_re​pos/reporter.c (drive):
>>> Move the function name to it's own line.
>> HACKING has examples like this:
>>
>> * dialects/nightingale.c (get_base_pitch): Allow 3/4-tone
>> pitch variation to account for trait variability amongst
>> isolated populations Erithacus megarhynchos.
>
> Oh, so it does.
>
> It's been a while since I've seen that format used, and we've seemed
> to standardize on the "separate line" format. Any objections to
> changing that example?
>
> -Hyrum

Well, if I have only one function name for a file, I remember having been
told to just write it out in one line. Makes sense to me...

* file.c (function): Rant.

* file2.c
  (function1): Rant.
  (function2): Rant.

But, blue, pink, I don't really care :)

~Neels
Attachments

Re: svn commit: r37806 - trunk/subversion/libsvn_repos

Author brane
Full name Branko Cibej
Date 2009-05-25 14:34:29 PDT
Message Hyrum K. Wright wrote:
>
> On May 25, 2009, at 2:51 PM, Branko Cibej wrote:
>
>> Hyrum K. Wright wrote:
>>> On May 25, 2009, at 9:19 AM, Stefan Sperling wrote:
>>>
>>>
>>>> On Mon, May 25, 2009 at 08:08:17AM -0500, Hyrum K. Wright wrote:
>>>>
>>>>> On May 24, 2009, at 3:55 PM, Neels Janosch Hofmeyr wrote:
>>>>>
>>>>>
>>>>>> Author: neels
>>>>>> Date: Sun May 24 13:55:35 2009
>>>>>> New Revision: 37806
>>>>>>
>>>>>> Log:
>>>>>> * subversion/libsvn_re​pos/reporter.c (drive):
>>>>>>
>>>>> Move the function name to it's own line.
>>>>>
>>>> HACKING has examples like this:
>>>>
>>>> * dialects/nightingale.c (get_base_pitch): Allow 3/4-tone
>>>> pitch variation to account for trait variability amongst
>>>> isolated populations Erithacus megarhynchos.
>>>>
>>>
>>> Oh, so it does.
>>>
>>> It's been a while since I've seen that format used, and we've seemed
>>> to standardize on the "separate line" format. Any objections to
>>> changing that example?
>>>
>>
>> Yes. Check the logs, we have hundreds of messages like that. IIRC this
>> is even the preferred form according to GNU log message conventions,
>> which we liberally stole from. Makes no sense to change Hacking if that
>> makes tons of our logs "bad', no?
>
> Do you have many recent examples?

My last commit, I suppose ...

> We also liberally stole from the GNU coding conventions, but they
> have evolved to fit our style. Just as we still have many "spaces
> before parens" in our code, I'm not suggesting we "fix" old log
> messages, but that we pick the format which is vastly prevalent
> presently, and standardize on it moving forward.
>
> But in the end, it's a bikeshed issue, and I've got bigger fish to
> fry, so I'm not going to press it. :)

Vermilion with orange spots.

-- Brane

Re: svn commit: r37806 - trunk/subversion/libsvn_repos

Author hwright
Full name Hyrum K. Wright
Date 2009-05-25 13:01:00 PDT
Message On May 25, 2009, at 2:51 PM, Branko Cibej wrote:

> Hyrum K. Wright wrote:
>> On May 25, 2009, at 9:19 AM, Stefan Sperling wrote:
>>
>>
>>> On Mon, May 25, 2009 at 08:08:17AM -0500, Hyrum K. Wright wrote:
>>>
>>>> On May 24, 2009, at 3:55 PM, Neels Janosch Hofmeyr wrote:
>>>>
>>>>
>>>>> Author: neels
>>>>> Date: Sun May 24 13:55:35 2009
>>>>> New Revision: 37806
>>>>>
>>>>> Log:
>>>>> * subversion/libsvn_re​pos/reporter.c (drive):
>>>>>
>>>> Move the function name to it's own line.
>>>>
>>> HACKING has examples like this:
>>>
>>> * dialects/nightingale.c (get_base_pitch): Allow 3/4-tone
>>> pitch variation to account for trait variability amongst
>>> isolated populations Erithacus megarhynchos.
>>>
>>
>> Oh, so it does.
>>
>> It's been a while since I've seen that format used, and we've seemed
>> to standardize on the "separate line" format. Any objections to
>> changing that example?
>>
>
> Yes. Check the logs, we have hundreds of messages like that. IIRC this
> is even the preferred form according to GNU log message conventions,
> which we liberally stole from. Makes no sense to change Hacking if
> that
> makes tons of our logs "bad', no?

Do you have many recent examples? We also liberally stole from the
GNU coding conventions, but they have evolved to fit our style. Just
as we still have many "spaces before parens" in our code, I'm not
suggesting we "fix" old log messages, but that we pick the format
which is vastly prevalent presently, and standardize on it moving
forward.

But in the end, it's a bikeshed issue, and I've got bigger fish to
fry, so I'm not going to press it. :)

-Hyrum

Re: svn commit: r37806 - trunk/subversion/libsvn_repos

Author brane
Full name Branko Cibej
Date 2009-05-25 12:51:36 PDT
Message Hyrum K. Wright wrote:
> On May 25, 2009, at 9:19 AM, Stefan Sperling wrote:
>
>
>> On Mon, May 25, 2009 at 08:08:17AM -0500, Hyrum K. Wright wrote:
>>
>>> On May 24, 2009, at 3:55 PM, Neels Janosch Hofmeyr wrote:
>>>
>>>
>>>> Author: neels
>>>> Date: Sun May 24 13:55:35 2009
>>>> New Revision: 37806
>>>>
>>>> Log:
>>>> * subversion/libsvn_re​pos/reporter.c (drive):
>>>>
>>> Move the function name to it's own line.
>>>
>> HACKING has examples like this:
>>
>> * dialects/nightingale.c (get_base_pitch): Allow 3/4-tone
>> pitch variation to account for trait variability amongst
>> isolated populations Erithacus megarhynchos.
>>
>
> Oh, so it does.
>
> It's been a while since I've seen that format used, and we've seemed
> to standardize on the "separate line" format. Any objections to
> changing that example?
>

Yes. Check the logs, we have hundreds of messages like that. IIRC this
is even the preferred form according to GNU log message conventions,
which we liberally stole from. Makes no sense to change Hacking if that
makes tons of our logs "bad', no?

-- Brane

Re: svn commit: r37806 - trunk/subversion/libsvn_repos

Author stsp
Full name Stefan Sperling
Date 2009-05-25 07:31:55 PDT
Message
Attachments

Re: svn commit: r37806 - trunk/subversion/libsvn_repos

Author hwright
Full name Hyrum K. Wright
Date 2009-05-25 07:24:29 PDT
Message On May 25, 2009, at 9:19 AM, Stefan Sperling wrote:

> On Mon, May 25, 2009 at 08:08:17AM -0500, Hyrum K. Wright wrote:
>> On May 24, 2009, at 3:55 PM, Neels Janosch Hofmeyr wrote:
>>
>>> Author: neels
>>> Date: Sun May 24 13:55:35 2009
>>> New Revision: 37806
>>>
>>> Log:
>>> * subversion/libsvn_re​pos/reporter.c (drive):
>>
>> Move the function name to it's own line.
>
> HACKING has examples like this:
>
> * dialects/nightingale.c (get_base_pitch): Allow 3/4-tone
> pitch variation to account for trait variability amongst
> isolated populations Erithacus megarhynchos.

Oh, so it does.

It's been a while since I've seen that format used, and we've seemed
to standardize on the "separate line" format. Any objections to
changing that example?

-Hyrum

Re: svn commit: r37806 - trunk/subversion/libsvn_repos

Author stsp
Full name Stefan Sperling
Date 2009-05-25 07:19:17 PDT
Message
Attachments

Re: svn commit: r37806 - trunk/subversion/libsvn_repos

Author hwright
Full name Hyrum K. Wright
Date 2009-05-25 07:06:22 PDT
Message On May 24, 2009, at 3:55 PM, Neels Janosch Hofmeyr wrote:

> Author: neels
> Date: Sun May 24 13:55:35 2009
> New Revision: 37806
>
> Log:
> * subversion/libsvn_re​pos/reporter.c (drive):

Move the function name to it's own line.

>
> Use svn_dirent_dirname() instead of svn_path_dirname()
> (deprecated).
>
> Modified:
> trunk/subversion/lib​svn_repos/reporter.c​
>
> Modified: trunk/subversion/lib​svn_repos/reporter.c​
> URL: http://svn.collab.ne​t/viewvc/svn/trunk/s​ubversion/libsvn_rep​os/reporter.c?pathre​v=37806&r1=37805​&r2=37806
> =
> =
> =
> =
> =
> =
> =
> =
> ====================​====================​====================​==========
> --- trunk/subversion/lib​svn_repos/reporter.c​ Sun May 24 11:35:26
> 2009 (r37805)
> +++ trunk/subversion/lib​svn_repos/reporter.c​ Sun May 24 13:55:35
> 2009 (r37806)
> @@ -1144,7 +1144,7 @@ drive(report_baton_t *b, svn_revnum_t s_
>
> /* Compute the target path corresponding to the working copy anchor,
> and check its authorization. */
> - t_anchor = *b->s_operand ? svn_path_dirname(b->t_path, pool) : b-
> >t_path;
> + t_anchor = *b->s_operand ? svn_dirent_dirname(b​->t_path, pool) :
> b->t_path;
> SVN_ERR(check_auth(b, &allowed, t_anchor, pool));
> if (!allowed)
> return svn_error_create
>
> --------------------​--------------------​--------------
> http://subversion.ti​gris.org/ds/viewMess​age.do?dsForumId=495​&dsMessageId=235​3358
Messages per page: