Login | Register
My pages Projects Community openCollabNet

Discussions > users [DISABLED] > Re: Strange behaviour of svnserve authz

Discussion topic

Back to topic list

Re: Strange behaviour of svnserve authz

Author klktrk
Full name Kristofer
Date 2009-04-10 11:52:54 PDT
Message I have the same problem, exactly as described, but with a later version of
svnserve, version 1.4.3 (r23084)
   compiled Jan 25 2007, 11:15:28

Copyright (C) 2000-2006 CollabNet.
Subversion is open source software, see http://subversion.tigris.org/
This product includes software developed by CollabNet

The following repository back-end (FS) modules are available:

* fs_fs : Module for working with a plain file (FSFS) repository.

My sense is they aren't really supporting the svnserve scenario much.

curious: do you have more than one repository? I copied my conf file from an
old repository to a new one, swapped out the repo names in the authz file,
and nothing worked. (same passwd, same groups, everything else), even though
the old repository worked fine. So the new repo seemingly can't handle the
new config, unless I rip it all out (disable the authz file), at which point
it works like a charm, but of course I can't configure paths, etc,.

Mathias Weinert-2 wrote:
> I found the following behaviour of svnserve which I found a bit
> strange (meaning: I wouldn't have expected it like this ;-) ).
> I am using 1.3.0-rc7 under cygwin.
> When my svnserve.conf file contains:
> [general]
> anon-access = none
> auth-access = write
> password-db = passwd
> #authz-db = authz
> everything works fine. I can only commit if I am a known
> subversion user.
> But then I activated the authz-db option to use the authz file.
> This file only contains:
> [/trunk]
> wallace = rw
> grommit = rw
> With this I cannot commit files in trunk any more:
> $ svn ci -m "test commit"
> Sending foo
> Transmitting file data .svn: Commit failed (details follow):
> svn: Access denied

View this message in context: http://www.nabble.co​m/Strange-behaviour-​of-svnserve-authz-tp​2167924p22992964.htm​l
Sent from the Subversion Users mailing list archive at Nabble.com.

« Previous message in topic | 2 of 2 | Next message in topic »


Show all messages in topic

Strange behaviour of svnserve authz Mathias Weinert <mathias dot weinert at gfa-net dot de> Mathias Weinert <mathias dot weinert at gfa-net dot de> 2006-01-02 02:19:45 PST
     Re: Strange behaviour of svnserve authz klktrk Kristofer 2009-04-10 11:52:54 PDT
Messages per page: